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Virtual TimeClock Frequently Asked Questions
  

Installation & Setup of Virtual TimeClock Software

How do I customize my employee time clock display?
You can adjust the program preferences to get just the look and functionality you want,
including how worker names are listed, what columns are displayed in the main time clock
window, and what menu items and toolbar buttons are available. Preferences are accessed
from the Virtual TimeClock menu on Macintosh OS X computers, and from the Edit menu
on Microsoft Windows computers.

Where do I enter worker leave awards?
Leave awards are given individually for each user and for each leave category as either an
annual award (80 hours per year) or a calculated award (1 hour paid leave per 40 hours
worked).

1. From the Lists menu, choose Users.
2. Click the Leave tab to open the Leave panel for the selected user.
3. You can now enter the award anniversary for each employee, new awards for the

upcoming year as either annual awards or calculated awards, and any leave
carryover hours from the prior benefit year.

4. Run the Accrued and Used Leave report to verify your leave totals.

How do I setup a Display Group?
Display Groups give management a powerful and flexible way to view and manage Virtual
TimeClock users by department or location when using networked time clocks. Display
groups also allow you to assign what tasks, memos, and reports workers are allowed to
use.

Setting up display groups is a four-step process:
1. Create a new display group:

1. From the Lists menu, choose Display Groups.
2. Click the + button beneath the list of display groups.
3. In the Name field, enter a unique display group name.
4. Click the Save button to add the new display group.

The Display Group list window provides a rapid means to add or remove users, tasks,
memos, or reports from different display groups.

2. Assign a manager to a display group:
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1. From the Lists menu, choose Users.
2. Select a user name from the list of users and click the Access tab.
3. Select a display group name and click the Manager checkbox.
4. Click the Save button to assign the user as a manager of the selected display

group.

3. Set management security and program access:
1. From the Tools menu, choose Security.
2. Click the Actions tab.
3. Set the management access for each desired program function by selecting Allow

Manager Access from the Other Group Members drop-down list.
4. Click the Reports tab and set the management access for each report.
5. Click the Save button.

4. Assign a display group to a time clock:
1. From the Lists menu of the Client TimeClock, choose Display Groups.
2. From the This TimeClock Uses drop-down list, select what display is to be used

by the time clock and click the Save button.

How do I move Virtual TimeClock software to another computer?
Moving your employee time clock software from one computer to another can be
performed quickly by using Virtual TimeClock's built-in backup and restore features.

Moving Virtual TimeClock Pro Desktop
1. From the File menu, choose Backup.
2. Select the Manual panel tab.
3. Click the Choose button to navigate to the location where you'd like to save the

backup file.
4. Click the Backup button to perform a manual backup.
5. Install and launch Virtual TimeClock Pro Desktop on the new computer.
6. From the File menu, choose Restore.
7. Navigate to the location where you've saved the backup file and open it.
8. Once the success of your data transfer has been confirmed on the new computer,

uninstall the Virtual TimeClock program from the old computer.
9. Register Virtual TimeClock Pro Desktop edition on the new computer according to

the instructions included with your registration information from Redcort Software.
10. Setup a new scheduled backup.

Moving Virtual TimeClock Server
1. Launch Virtual TimeClock Server and click the Backup toolbar button.
2. Click the Choose button to navigate to the location where you'd like to save the

backup file.
3. Click the Backup Now button.
4. Remove the Virtual TimeClock Server background daemon or service.
5. Install and launch Virtual TimeClock Server on the new computer.
6. Add the Virtual TimeClock Server background daemon or service.
7. Choose your new database folder location.
8. From the File menu, choose Restore Database.
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9. Navigate to the location where you've saved the backup file and open it.
10. Once the success of your data transfer has been confirmed on the new computer,

uninstall the Virtual TimeClock Server program from the old computer.
11. Register Virtual TimeClock on the new computer according to the instructions

included with your registration information from Redcort Software.
12. Setup a new scheduled backup.
13. Reconnect your client TimeClocks by choosing Connect To TimeClock Server from

the File menu of each client TimeClock computer.

Moving Virtual TimeClock Pro Client
1. Virtual TimeClock remembers all client TimeClocks that have ever connected to the

TimeClock Server, so you'll need to delete the client that you'll no longer be using.
2. Quit the Virtual TimeClock program on the old client TimeClock computer.
3. Launch Virtual TimeClock Server and click the Licenses toolbar button.
4. Select the registered client you wish to delete and click the Remove Client button.
5. Install and launch Virtual TimeClock Pro Client on the new computer.
6. From the File menu, choose Connect to TimeClock Server.
7. Once you have successfully connected from the new client TimeClock computer,

uninstall the Virtual TimeClock program from the old computer.

Does Virtual TimeClock work with biometric devices or bar code readers?
No. Virtual TimeClock does not interface with biometric devices or bar code readers. 

As a software only solution, Virtual TimeClock is a cost effective time and attendance
system without the need to buy or support proprietary hardware devices.

Will Virtual TimeClock run in a Terminal Services environment?
The Network Edition runs well on a Terminal Server. The stand alone (Basic and Pro)
Editions of Virtual TimeClock do not run in a Terminal Services environment.

Please note: 
We recommend loading the Virtual TimeClock client application on the Terminal Server,
pointing to the Virtual TimeClock server application on another server or computer.

What are the system requirements for Virtual TimeClock?
The system requirements for Virtual TimeClock are on our web site at
http://redcort.com/download/time-clock-software-requirements.html.

Upgrading Virtual TimeClock Software

What does is cost to upgrade to the latest Virtual TimeClock release?
Upgrades are always free of charge for users enrolled in our optional Software
Maintenance & Support program. Upgrade rebates are available for registered users of
prior versions of Virtual TimeClock.

Please contact Redcort Software for upgrade pricing or Maintenance & Support enrollment
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eligibility.

How do I upgrade to the latest Virtual TimeClock software release?
Detailed upgrade instructions are available on our upgrade page here.

Networking Virtual TimeClock

Why can't my TimeClock Client connect to the Virtual TimeClock Server?
If you can't connect to the Virtual TimeClock Server, it's likely due to one or more of the
following issues:

1. The Virtual TimeClock Server is not installed or not running. Launch Virtual
TimeClock Server and check the Status window to ensure all server functions are
running and online.

2. The firewall on the server has not been set to allow Virtual TimeClock to accept
network connections. Virtual TimeClock uses TCP port 56777 and UDP port 56778
by default for network communications.

3. Antivirus software is blocking port communications between the TimeClock Server
and client TimeClock.

4. The server and client computers are not on the same local network. In this case,
the client TimeClock needs access to the TimeClock Server from outside the
network (see the next question for instructions on setting up Remote Connections).

Can I use Virtual TimeClock connecting from more than one location over the Internet?
Yes. Virtual TimeClock Network Edition can be configured to allow a Virtual TimeClock
client to connect to a TimeClock Server at a remote location over the Internet. 

See the following guide for setup details: Using Virtual TimeClock Over the Internet
(pdf)

How do I set my Windows Firewall to allow the TimeClock Server service to communicate on
my network?
You'll need to add an exception to your Windows Firewall for the Virtual TimeClock
Service.

Windows XP
1. From the Control Panel, open Windows Firewall.
2. Click the Exceptions tab and then click Add Program.
3. Click the Browse button and navigate to C:\Program Files\Virtual TimeClock Server

'10\TimeClock Server\Virtual TimeClock Service and click the Open button.
4. Virtual TimeClock Service will now be added to your list of programs so you can

select it and click the OK button.
5. Click the OK button to close Windows Firewall.

Windows Vista
1. From the Control Panel, open Windows Firewall.



Frequently Asked Questions About Virtual TimeClock Software

- 5 -http://www.redcort.com/support/virtual-time-clock-software-FAQ.htmlVirtual TimeClock & Virtual TimeClock Pro are registered trademarks of Redcort Software, Inc. ©2012 Redcort Software, Inc. All Rights 
Reserved.

2. Click Allow a program through Windows Firewall.
3. Click the Add Program button.
4. Click the Browse button and navigate to C:\Program Files\Virtual TimeClock Server

'10\TimeClock Server\Virtual TimeClock Service and click the Open button.
5. Virtual TimeClock Service will now be added to your list of programs so you can

select it and click the OK button.
6. Click the OK button to close Windows Firewall.

Windows 7
1. From the Control Panel, open Windows Firewall.
2. Click Allow a program or feature through Windows Firewall.
3. Click the Add another program button.
4. Click the Browse button and navigate to C:\Program Files\Virtual TimeClock Server

'10\TimeClock Server\Virtual TimeClock Service and click the Open button.
5. Virtual TimeClock Service will now be added to your list of programs so you can

select it and click the Add button.
6. Click the OK button and close Windows Firewall.

Licensing Virtual TimeClock

When my free time clock software evaluation ends and I purchase a license key, will I lose
my existing time clock data?
No. Entering your new license key will only remove the evaluation restrictions. All of the data you
entered during the evaluation period will remain intact.

What do I do if my license key activation fails?
Your company name and address information must be entered into Virtual TimeClock
exactly as it appears on your software license from us. 

Capitalization and punctuation must match. An easy way to guarantee accurate entry is to
copy and paste the company name, address, and license key text from the license email
into the appropriate registration window fields in Virtual TimeClock.

If you are unable to get your product properly registered, contact us with your company
name and the product registration information you are using.

Why am I getting an 'Out of licenses' error on a client TimeClock?
Virtual TimeClock remembers all client TimeClocks that have ever successfully connected
to the TimeClock Server. To connect new client TimeClock computers, you'll need to
delete clients no longer using Virtual TimeClock.

1. Launch Virtual TimeClock Server and click the Licenses toolbar button.
2. Select the registered client you wish to delete and click the Remove Client button.
3. Click the Continue button to confirm removing the old registered client.

What if I've lost or misplaced my software license keys?
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Contact us with your company name and the product registered and we'll be happy
to provide you a copy of your software licenses.

Why does Virtual TimeClock tell me that my Maintenance & Support has expired or I am not
enrolled when I attempt to upgrade?
This indicates the Virtual TimeClock license you are currently using is not valid for use
with the upgrade you are installing.

If you have renewed your Maintenance & Support, you probably have not yet entered your
new license keys. Detailed instructions for entering your new license keys are included
with your renewal license from us.

Contact us if you need a copy of your renewal license keys, want to enroll your licenses in
Maintenance & Support, or purchase an upgrade.

Virtual TimeClock Program Behavior

What do I need to do at the end of a payroll period?
We've prepared a short guide that explains the considerations and things you'll want to do at the
conclusion of each employee payroll period:
Virtual TimeClock End of Period Procedures Guide (pdf)

Can a timecard entry be modified after the payroll period has already been closed?
Yes. In order to modify a timecard entry in a previously closed period, you must first reopen the
closed payroll period.

What is the difference between a task and an out status memo?
Tasks are activities you pay an employee to do, it's time 'on the clock'. Out status memos are notes
left when employees are 'off the clock' and not being paid. Unlike tasks, out status memos are not
stored after the next timecard entry.

Confusing these two may cause you to count 'off the clock' time as 'on the clock', and vice-versa.

Can overtime settings be different for each employee?
Yes. A different overtime rule can be assigned to each individual worker. This makes it easy to
place your employees on alternative work schedules.

What if I don’t remember my Administrator level password?
Please contact us with your name, company, and the version of Virtual TimeClock you are
using.

Can Virtual TimeClock automatically deduct a lunch break so workers do not have to clock
out?
Yes, you can setup as many different automatic time deduction rules as you want and
assign a different rule to each worker.
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Can Virtual TimeClock export timecard data to my payroll software?
Maybe. Virtual TimeClock supports an easy to use interface that exports your timecard
totals directly into CheckMark Payroll.

You can also export timecard data to a tab or comma separated text file. Export files can
be opened and edited in any common text editor or spreadsheet software (such as
Microsoft Excel), formatting the data for import into any standard accounting/payroll
software that allows text file importing.

Can Virtual TimeClock keep track of time spent on different jobs?
Yes. You can use tasks to track different accounts, activities, or jobs. 

Workers can use the 'Change Task' toolbar icon in the main TimeClock window to quickly
switch from one task to another without actually stopping work. Tasks allow you to track
all time 'on the clock' and generate reports based on those different tasks.

How do I backup my timecard data?
Virtual TimeClock has a built-in backup utility that allows you to easily and quickly
schedule automated backups.

Virtual TimeClock Pro Desktop (Stand Alone) Backups

1. From the File menu, choose Backup.
2. Select the Schedule tab.
3. Click the Choose button to navigate to the location where you'd like to save the

backup file.
4. In the Schedule section, select the appropriate radio button to schedule a backup

to occur Every Day, Weekdays, Weekends, or a specific day of the week.
5. Select the time you want the backup to occur from the drop-down list.
6. Click the Save button to schedule your backup.

Virtual TimeClock Server Backups

1. Launch Virtual TimeClock Server and click the Backup toolbar button.
2. Click the Choose button to navigate to the location where you'd like to save the

backup file.
3. In the Schedule section, select the appropriate radio button to schedule a backup

to occur Every Day, Weekdays, Weekends, or a specific day of the week.
4. Select the time you want the backup to occur from the drop-down list.
5. Click the Save button to schedule your backup.

How do I reopen a closed payroll period?
It's easy to reopen a closed payroll period.

1. From the Tools menu, choose Payroll Period.
2. In the Current Period section, set the start and end dates for the payroll period

you want to open.
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3. Click the Save button to reopen the period.

How do I keep employees from buddy punching?
You'll want to enable password protection.

1. From the Tools menu, choose Security.
2. Select the Enable Password Protection checkbox.
3. Click the Save button to enable password protection.

Virtual TimeClock Reports

Why does weekly overtime seem incorrect when the worker used paid leave time during the
same week?
Virtual TimeClock does not include leave hours in weekly overtime calculations. The prevailing rule
among the different States is that weekly overtime is calculated on hours worked only.

Why doesn't my timecard report seem to total hours correctly after turning on quarter hour
rounding?
Quarter hour rounding is performed on the actual start and stop times, NOT on the total hours
worked. 

This is an industry standard. Quarter hour rounding is widely used to consistently pay workers for a
40-hour week. By rounding the start and stop times to the nearest quarter hour, a worker will
always get paid for 8 hours per day and 40 hours per week despite the fact they may come in
'about' 8 AM and leave 'about' 5 PM with 'about' a one hour lunch.

Why do employee timecards keep showing an old payroll period and not the current one?
Select 'Close Payroll Period' under the Tools Menu to advance to the next period. Closing the
payroll period automatically advances the current period starting and ending dates to the next
payroll period based on your payroll settings.

Why do my YTD leave totals appear incorrect on the Accrued and Used Leave report?
All Year-To-Date totals are calculated from the award anniversary date of each employee,
and that may not necessarily be January 1. It's easy to change a worker's award
anniversary date if you need to.

1. From the Lists menu, choose Users.
2. Select a user name from the list of users and click the Leave tab.
3. Set the award anniversary month and day from the drop-down lists.

Why are totals missing from my timecard report?
When timecards are missing some or all of the daily totals, it's almost always due to the
payroll period being closed before all of the entries have been made for the period. When
a period is closed, the program calculates and saves the totals based on the current
payroll settings so any additional entries are then left untotaled.

Fortunately, it's easy to reopen a closed payroll period:
1. From the Tools menu, choose Payroll Period.
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2. In the Current Period section, set the start and end dates for the payroll period
you want to open.

3. Click the Save button.

Other Questions About Virtual TimeClock

Does Virtual TimeClock calculate payroll taxes and Social Security deductions?
No. These calculations are a function of payroll. 

Virtual TimeClock is time and attendance software. It performs the necessary steps prior to payroll,
including the capture and accurate calculation of employee hours and overtime worked.

How do I request a new feature?
To request a new feature, simply contact us by telephone or email. 

Describe generally or specifically what you would like added or changed in the program. It
is very helpful if you explain how you would use the feature and why it is important to
you. As part of our bi-annual engineering review, we evaluate all feature requests using a
matrix based on three criteria:

How well does the feature request fit logically with our existing feature set?
How much engineering time and effort will be required to implement the feature?
How many customers have requested this feature?

While we don't promise new features or forecast release dates for software in
development, we will let you know if your feature request has been implemented in a new
software release.

How do seasonal time changes impact my Virtual TimeClock software?
For most users, there’s no impact at all. 

Virtual TimeClock records all time stamps from the computer hardware running the
TimeClock database. In other words, Virtual TimeClock records the time as reported by
your computer. As long as your computer handles the time change automatically, Virtual
TimeClock will always automatically record the correct time for you. If you have worker
shifts that cross the time change, you do need to manually add or subtract an hour for
that shift, depending on the time of year.
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